注册 登录  
 加关注
查看详情
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

毛凌国.中国 官方博客

国际商业美术设计师协会高级平面美术设计师,职业画家,狮龍畫廊CEO,知名学者。

 
 
 

日志

 
 
关于我

国际商业美术设计师协会高级平面美术设计师,职业画家,狮龍畫廊CEO,便携式结构设计发明人,第一代中国第一汽车集团公司广告美术设计者,自由编辑专稿人,知名学者。

 
 

CISCO2500系列路由器基本知识说明  

2011-08-25 17:34:47|  分类: 我的公司工程部设 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |
 

其中用enable password设置的口令是没有进行加密的,可以查看到口令字符串:用enable secret设置的口令是加密的,设置后无法查看到口令字符串。 注意:设置完口令后,一定不要忘记,否则,要进入超级权限模式很麻烦,在某些情况下,除非重新回忆起口令,否则,你就无法进入超级权限模式 其它设置模式这里主要介绍几种其它设置模式要进入其它设置模式,首先必须进入全局设置模式端口设置模式  在全局设置模式下:
  interface端口号2500、1600系列的端口主要有:
  ☆ interface serial号码:高速同步串口的号码由0开始
  ☆ interface ethernet号码:由0开始
  ☆ interface async号码:象2509,2511有专门的异步端口的路由器,AUX口为async0,其它的专门的异步口由1开始编号。AUX口在所有2500系列路由器上编号为async1
  ☆ line con 0:配置console口。为安全起见,可以配置口令。配置如下:line con 0| login|password 口令字符串建议:不要轻易配置Login及口令,否则,一旦忘记,再进入路由器很麻烦。
SETUP模式
  SETUP模式是用对话的方式,即一问一答的方式实现对路由器的配置,但这种方式只能对路由器进行简单的配置,无法实现进一步的配置。
  新路由器第一次进行配置时,系统会自动进入SETUP模式,并询问是否用SETUP方式进行配置。在任何时候,要进入SETUP模式,在超级权限模式下,键入setup.
RXBOOT模式
  在路由器出现问题时,有时可以进入RXBOOT模式解决。有两种方式可以进入RXBOOT模式。
  方法1:在路由器加电60秒内,在Windows95或NT的超级终端下,同时按ctrl+break键3-5秒左右就进入RXBOOT模式。
  方法2:在全局设置模式下,config-register oxo,然后关闭电源重启动,或在超级权限下,键入:reload
则进入RXBOOT模式,其提示符为:〉
  在这里介绍一下,RXBOOT模式的一种用途:如果丢失进入超级权限的口令怎么办?如果BREAK键没有被封锁,还有救,否则。。。。。。
2500系列路由器步骤
  在Windows95或NT的超级终端下:
  1. 重新加电,并在路由器启动60秒内,同时按Ctrl+Break键3-5秒,进入RXBOOT模式
  2. 改变寄存器值:> o/r 0x42
  3. 重新初始化:> i
  4. 这时,路由器将跳过原有配置,也就是没有超级权限的口令。进入超级权限模式,重新设置超级权限的口令,在全局设置模式下:enable secret 口令字符串
  5. 在全局设置模式下,恢复寄存器值到原来的位置: config-register 0x2102
  6. 在超级权限模式下,保存配置:copy run start
  7. 重新加电,或在超级权限模式下,重新热启动路由器,输入:reload
  对于1600系列路由器除了第2、3步命令不同,其它步骤与2500系列路由器完全一样。
  2. 修改寄存器值:confreg 0x42

3. 通过TELNET方式进行配置。可以在网络中任一位置对路由器进行配置。主要你有足够的权力,当然,也需要您的计算机支持Telnet。
  4. 通过网管工作站进行配置,这就需要在您的网络中有至少一台运行CiscoWorks及CiscoView等的网管工作站。需要另外购买网管软件。
  5. 通过tftp服务器下载路由器配置文件,可以用任何没有特殊格式的纯文本编辑器编辑路由器配置文件,并将其存放在tftp服务器的根目录下,采用手动方式或Autoinstall方式下载路由器配置文件。
  首先我们主要介绍一下利用Console口的设置方式,这里我们主要用Windows98下的超级终端。
  Cisco2500、1600提供了一条Console线(两头均为RJ-45)及三个RJ-45转换头。
  一般的,选择PC机的COM1或COM2口,选用RJ45-DB9或RJ45-DB25的转换头与COM口连接,再将Console线接入Console口中华人民共和国。采用VT100终端方式。这时,你就会进入路由器的命令行状态,你就可以操纵路由器了。
命令行配置模式
  在命令行状态下,主要有几种工作模式:
  一般用户模式
  从Console口或AUX口进入路由器时,首先要进入一般用户模式。在一般用户模式下,用户只能运行少数命令,且不能对路由器进行配置,在没有进行任何配置的情况下,缺省的路由器提示符为:Router> ,如果设置了路由器的名字,则提示符为:路由器的名字>
  超级权限模式
  在缺省状态下,超级权限模式下可以使用比一般用户模式下多得多的命令,绝大多数命令用于测试网络,检查系统等,不能对端口及网络协议进行配置。在没有进行任何配置的情况下,缺省的超级权限提示符为:Router#
在配置了路由器的名字之后,超级权限模式的提示符为:路由器的名字#。这里介绍第一条命令由一般用户模式切换到超级权限模式下键入:enable,在没有任何设置下,键入该命令即可进入超级权限模式下,如果设置了口令,则需要输入口令。另外,介绍一组配置时经常用到的命令:copy命令
  copy 源位置目的位置
  表示将由某个源位置所指定的文件复制到目的位置所指定处,与DOS或Win98下的COPY命令功能一致。其中Cisco2500,1600系列中源和目的位置可以为Flash、Dram、Tftp、NVRAM
  对于配置文件来说,参数值run表示存放在DRAM中的配置。Start表示存放在NVRAM中的配置。
  所有的配置命令只要键入后马上存在DRAM中并运行,但掉电后会马上丢失,而NVRAM中的配置只有在重新启动之后才会被复制到DRAM中运行,掉电不会丢失,因此,必须养成好的配置习惯,在确认配置正确后将配置文件复制到NVRAM中去,其命令是:copy run start
  如果想用NVRAM中的配置覆盖DRAM中的配置命令 copy start run
  可以将NVRAM中的配置复制到tftp服务器中进行备份,用命令: copy start tftp
  可以将DRAM中的配置复制到Tftp服务器中进行备份,用命令:copy run tftp
  路由器会询问你Tftp服务器的IP地址及以何文件名存放,输入正确的服务器IP地址和文件名后,即可。可以从Tftp中复制配置文件到路由器的DRAM中,用命令:copy tftp run
  可以从Tftp中复制配置文件到路由器的NVRAM中,用命令:copy tftp start
  路由器会询问你Tftp服务器根目录下的配置文件名以及在路由器上以什么名字复制该配置文件。
  如果想删掉NVRAM中的所有配置用命令:write erase
全局配置模式
  全局设置模式下可以设置一些全局性的参数,要进入全局设置模式,必须首先进入超级权限模式,然后,在超级权限模式下键入config terminal回车即进入全局设置模式。其缺省提示符为Router(config)#
  这里先介绍几个配置命令
  配置路由器的名字:hostname 路由器的名字
  设置进入超级权限时的口令:enable password 口令字符串 或 enable secret 口令字符串

  其中用enable password设置的口令是没有进行加密的,可以查看到口令字符串:用enable secret设置的口令是加密的,设置后无法查看到口令字符串。
  注意:设置完口令后,一定不要忘记,否则,要进入超级权限模式很麻烦,在某些情况下,除非重新回忆起口令,否则,你就无法进入超级权限模式其它设置模式这里主要介绍几种其它设置模式要进入其它设置模式,首先必须进入全局设置模式端口设置模式在全局设置模式下:
  interface端口号
  2500、1600系列的端口主要有:
  ☆ interface serial号码:高速同步串口的号码由0开始
  ☆ interface ethernet号码:由0开始
  ☆ interface async号码:象2509,2511有专门的异步端口的路由器,AUX口为async0,其它的专门的异步口由1开始编号。AUX口在所有2500系列路由器上编号为async1
  ☆ line con 0:配置console口。为安全起见,可以配置口令。配置如下:line con 0| login|password 口令字符串
  建议:不要轻易配置Login及口令,否则,一旦忘记,再进入路由器很麻烦。
SETUP模式
  SETUP模式是用对话的方式,即一问一答的方式实现对路由器的配置,但这种方式只能对路由器进行简单的配置,无法实现进一步的配置。
  新路由器第一次进行配置时,系统会自动进入SETUP模式,并询问是否用SETUP方式进行配置。在任何时候,要进入SETUP模式,在超级权限模式下,键入setup.
RXBOOT模式
  在路由器出现问题时,有时可以进入RXBOOT模式解决。有两种方式可以进入RXBOOT模式。
  方法1:在路由器加电60秒内,在Windows95或NT的超级终端下,同时按ctrl+break键3-5秒左右就进入RXBOOT模式。
  方法2:在全局设置模式下,config-register oxo,然后关闭电源重启动,或在超级权限下,键入:reload
则进入RXBOOT模式,其提示符为:〉
  在这里介绍一下,RXBOOT模式的一种用途:如果丢失进入超级权限的口令怎么办?如果BREAK键没有被封锁,还有救,否则。。。。。。
2500系列路由器步骤
  在Windows95或NT的超级终端下:
  1. 重新加电,并在路由器启动60秒内,同时按Ctrl+Break键3-5秒,进入RXBOOT模式
  2. 改变寄存器值:> o/r 0x42
  3. 重新初始化:> i
  4. 这时,路由器将跳过原有配置,也就是没有超级权限的口令。进入超级权限模式,重新设置超级权限的口令,在全局设置模式下:enable secret 口令字符串
  5. 在全局设置模式下,恢复寄存器值到原来的位置: config-register 0x2102
  6. 在超级权限模式下,保存配置:copy run start
  7. 重新加电,或在超级权限模式下,重新热启动路由器,输入:reload
  对于1600系列路由器除了第2、3步命令不同,其它步骤与2500系列路由器完全一样。
  2. 修改寄存器值:confreg 0x42
 3. 重新初始

· 多重引导IOS缺省情况下,Cisco路由器在FLASH中寻找IOS并启动IOS,如果FLASH中没有,会启动ROM中IOS。可以设置Cisco路由器可以有多个引导源, 以实现多重引导,在一些对安全较高的环境中,多重引导是需要的。多重引导表示路由器按照先后顺序,依次寻找IOS,如果前面所指定的位置没有,则到下面的位置找IOS。Cisco2500,1600系列可以从FLASH,tftp服务器,ROM中启动IOS。
  注意:如果从tftp服务器启动IOS,一般地,Cisco2500,1600路由器至少应有16M DRAM,因为所有IOS首先以tftp服务器中下载到路由器的DRAM中,另外,要求tftp服务器必须正在运行,IOS软件在tftp服务器的根目录下。tftp服务器必须与Cisco路由器的某个活动端口在同一网段。一般tftp服务器在本地局域网中。多重启动配置如下:
  一般地启动顺序为FLASH,tftp,ROM,在ROM中启动,则路由器基本无法完成正常的网络功能。
  1. 首先,从FLASH中启动,在全局设置状态下
  boot system flash
  2. 然后,从tftp服务器中启动,在全局设置模式下
  boot system tftp IOS文件名 tftp服务器IP地址
  3. 最后,从ROM中启动,在全局设置模式下
  boot system rom
  4. 在全局设置模式下设置寄存器值
  config-register 寄存器值
  Cisco路由器中的PC寄存器为16位。最低4位,该值如果为3-F(16进制),表示可以由BOOT命令设置的地点启动IOS。
  一般为0x2103-0x210F
实例:
Current configuration:
version 11.2
service config
no service udp-small-servers
no service tcp-small-servers
!
hostname kim
!
boot system flash
!首先,从FLASH中启动
boot system tftp c2500-j-l_112-9_p.bin 10.1.1.33
!之后,从tftp服务器中启动
!IOS文件名为c2500-j-l_112-9_p.bin,tftp 服务器地址为10.1.1.33
boot system rom
!最后,从ROM中启动
!
interface Ethernet0
ip address 10.1.1.1 255.255.255.0
no ip mroute-cache
no ip route-cache
!
interface Serial0
ip address 10.1.2.1 255.255.255.0
no ip mroute-cache
no ip route-cache
!
interface Serial1
no ip address
no ip mroute-cache
no ip route-cache
shutdown
!
no ip classless
!
line con 0
line 1 8
transport input all
line aux 0
transport input all
line vty 0 4
login
!
end
                            · 从服务器中自动下载路由器配置文件
  路由器的配置文件可以存放在tftp,rcp或MOP服务器中,通过一定的设置,路由器在启动后可以自动下载路由器配置文件。路由器需要下载两个文件,也可以下载其中的一个文件,这个文件合在一起成为运行的配置。
  1. 网络共用文件
  该文件包含有几个路由器共同的配置文件。
  2. 私有配置文件
  该文件包含有某台路由器特有的配置信息。
  这两个文件可用任何纯文本编辑器进入编辑
  一般地,要从tftp服务器中下载配置文件的网络拓朴,如图:
  下载网络共用文件的配置步骤
  1. 在全局设置模式下,启动路由器配置文件下载功能
  service config
  2. 在全局设置tftp服务器中下载网络共用配置文件
  boot network tftp 网络共用配置文件名 tftp服务器IP地址
  3. 在端口设置状态下,设置端口IP地址
  ip address 本地端口IP地址 子网掩码
  下载私有配置文件配置步骤
  1. 在全局设置模式下,启动路由器下载配置文件功能
  service config
  2. 在全局设置模式下,设置路由器从tftp服务器中下载私有配置文件
  boot host tftp私有配置文件名 tftp服务器IP地址
  3. 在端口设置状态,设置端口IP地址
  ip address 本端口IP地址 子网掩码

实例:
current configuration:
!
version 11.2
service config
no service udp-small-servers
no service tcp-small-servers
!
hostname kim
!
boot host try-host 10.1.1.33

!从地址为10.1.1.33的tftp服务器中下载名为try-host的私有配置文件
boot network try-network 10.1.1.33
!从地址为10.1.1.33的tftp服务器中下载名为try-network的网络共用文件
boot system flash
boot system tftp c2500-j-l-112-9_p.bin 10.1.1.33
boot system rom
!


interface Ethernet0
ip address 10.1.1.33 255.255.255.0
no ip mroute-cache
no ip route-cache
!
interface Serial0
no ip address
no ip mroute-cache
no ip route-cache
!
interface Serial1
no ip address
no ip mroute-cache
no ip route-cache
shutdown
!
no ip classless
!
line con 0
line 1 8
transport input all
line aux 0
transport input all
line vty 0 4
login
!
end
try-network文件内容
ip host kim 10.1.1.1
ip host try 10.1.2.1
ip host try 10.1.3.1
chat-sc lab ABORT ERROR ABORT BUSY " " ATDT \T " TIMEOUT 60 CONNECT \c
try-host文件内容
!
version 11.2
service config
no service udp-small-servers
no service tcp-small-servers
!
hostname kim
!
boot host try-host 10.1.1.33
boot network try-network 10.1.1.33
boot system Flash
boot system c2500-j-l_112-9_p.bin 10.1.1.33
boot system rom
!
interface Ethernet0
ip address 10.1.1.1 255.255.255.0
no ip mroute-cache
no ip route-cache
!
interface Serial0
ip address 10.1.2.1 255.255.255.0
no ip mroute-cache
no ip route-cache
!
interface Serial1
no ip address
no ip mroute-cache
no ip route-cache
shutdown
!
no ip classless
!
line con 0
line 1 8
transport input all
line aux 0
transport input all
line vty 0 4
login
!
end
                                        · 配置Autoinstall 功能
  cisco 2500,1600系列路由器在没有任何配置之前,可以自动启动autoinstall自动配置功能即路由器会自动地到tftp服务器中寻找配置文件,并下载运行。配置文件需要事先编辑好,并存放在tftp服务器的根目录下:
  要启动自动配置功能,必须满足以下条件:
  1. 路由器的物理线路必须事先接通。Cisco路由器可以通过以下几个端口找到tftp服务器。
  · 以太端口
  · 令牌环端口
  · FDDI端口
  · 用cisco HDLC或帧中继封装的同步串口
  Cisco 2500,1600系列路由器的高速同步串口在缺省状态下封装的协议为Cisco HDLC
  注意:如果在HDLC封装的端口无法实现自动配置功能,则路由器会自动在该端口上封装帧中继。
  2. 新路由器的完整或最小的配置,必须存放在tftp服务器的根目录下,且tftp服务器必须正在运行。
  3. 如果通过已配置好且正在与新路由器通过HDLC封装的端口相连的路由器帮助实现自动配置功能,则已配置好的路由器的该端口的IP地址的最后一个字节必须为1或2。(帧中继无此限制)
  4. 如果通过已配置好的路由器的帧中继封装的端口帮助新路由器实现自动配置功能,已配置的路由器必须进行如下配置:
  · 定义IP helper地址指向tftp服务器
  · IP helper address tftp服务器的IP地址
  · 映射新路由器的IP地址
  frame-relay map ip新路由器的与该端口的IP地址,本地帧中继地址
5. 如果通过已配置好的路由器的以太端口,令牌环端口,FDDI端口帮助新路由器实现自动配置功能,则这些端口所连接的网段上必须有BOOTP或RARP服务器.且必须将新路由器的MAC地址与IP地址进行映射。
  6. 有时可能需设置 IP helper地址帮助传输tftp及DNS广播。以下介绍通过HDLC封装的端口实现自动配置。
  自动配置工作过程,如图:
   1. 首先,新路由器需要得到与已存在的路由器相连的通过HDLC封装的端口的IP地址。这里即是Router A的Serial 1端口。新路由器通过SLARP广播寻找。如果已配置好的路由器的与其相连的端口,这里即是Router B的Serial 0端口的IP地址的最后一个字节为1,则Router A的Serial1的IP地址的最后一个字节为2,如果Router B的Serial 0的地址的最后一个字节为2,则Router A的Serial 1 IP地址的最后一个字节为1。
  2. 之后,新路由器需要知道自己的名字。如果在tftp服务器上,它会寻找一个名字为network-config或Cisconet.cfg的文件。在这个文件中,必须有Router A serial 1 端口的IP地址与新路由器名字的映射,这里
Router A的名字为Kim。
  3. 在新的路由器找到自己的名字之后,它会在tftp服务器的根目录下寻找自己的配置文件。配置文件的名字为:
  新路由器的名字-confg
  这里Router A的配置文件名为Kim-confg
  4. 新的路由器下载配置文件,并装DRAM中运行。
实例:
已配置好的路由器Router B的配置
kim#sho run
Building configuration…
Current configuration:
!
version 11.2
no service udp-small-servers
no service tcp-small-servers
!
hostname kim1
!
boot system flash
boot system rom
!
interface Ethernet0
ip address 10.1.1.1 255.255.255.0
no ip mroute-cache
no ip route-cache
!
internet Serial0
ip address 192.192.192.1 255.255.255.0
iup helper-address 10.1.1.33
!广播地址指向tftp服务器
no ip mroute-cache
no ip route-cache
!本实例用V.35 线缆直连模拟DDN专线,HDLC的配置请参照HDLC 配置章节
bandwidth 2000
! 带宽为2M
clockrate 2000000
!同步时钟
interface Serial1
no ip address
no ip mroute-cache
no ip route-cache
shutdown
!
no ip classless
!
line con 0
line 1 8
transport input all
line aux 0
transport input all
line vty 0 4
login
!
end
network-confg文件的内容:
ip host kim 192.192.192.2
!新路由器RouterA的高速同步串口1的地址与名字映射
ip host try 10.1.2.1
ip host try1 10.1.3.1
kim-confg文件的内容
int e0
ip add 193.1.3.1 255.255.255.0
int e1
ip add 192.1.2.1 255.255.255.0
ip route 0.0.0.0 0.0.0.0 192.192.192.1
RouterA的自动启动过程及启动后的执行配置
%SYS-5-RELOAD:Reload requested
System bootstrap,Version 11.2(10c),SOFTWARE
Copy right ? 1986-1996 by cisco Systems
2500 processor with 2048Kbytes of main memory
Notioce:NVRAM invalid, possibly due to write erase.
F3:5173084+61848+255460 at 0x3000060
Restricted Rights Legend
Use,duplication,or disclosure by the Government is subject to restrictions as set forth in subparagraph (c) of the commercial Computer Software -Restricted Rights clause at FAR sec.52.227-19 and subparagraph (c)(1)(ii) of the Rights in Technial Data and Computer Software clause at DFARS sec.252.225-7013.
Cisco Systems,inc.
170 West Tasman Drive
San Jose,california 95134-1706
Cisco internetwork Operating System Software
IOS(tm) 2500 software (c2500-D-L), version 11.2(5),RELEASE SOFTWARE(fc1)
Copyright (c) 1986-1997 by cisco systems inc.
Compiled Mon 31-Mar-97 20:17 by ckralik
Image text-base:0x302a734 data-base:0x00001000
Cisco 2500 (68030) processor (revision L) with 2048K/2048K bytes of memory.
Processor board ID 06246045, with hardware revision 00000000
Bridging software.
X.25 software,version 2.0, NET2 BFE and GOSIP compliant.
2 Ethernet/IEEE 802.3 interface(s)
2 Serial network interface(s)
32K byte of non-volatile configuration memory.
8192K bytes of processor board system Flash (Read ONLY)
Notice: NVRAM invalid, possibly due to write erase.
SLARP: interface Serial resolved. This interface has been automatically resolved thru the SLARP process. The router w ill now attempt to retrieve its name and configuration file.
Loading network-config from 10.1.1.33 (via Serial1):!
!新路由器RouterA在tftp服务器中找到network-confg文件
[OK - 74/32723 bytes]
configuration mapped ip address 192.192.192.2 to kim
! 新路由器RouterA的名字为kim,地址为192.192.192.2
Loading kim-confg from 10.1.1.33 (via serial1):!
[OK -122/32723 bytes]
! 新路由器RouterA从tftp服务器中成功下载自己的配置文件,名为kim-confg
SETUP:new interface Serial0 placed in "shutdown " state
Press RETURN to get started!
%LINK - 5 -SLARP: Serial1 address 192.192.192.2, resolved by 192.192.192.1
%LINK - 3 -UPDOWN interface Ethernet0, changed state to up
%LINK - 3 -UPDOWN interface Ethernet1, changed state to up
%LINK - 3 -UPDOWN interface serial0, changed state to down
%LINK - 3 -UPDOWN interface serial1, changed state to up
%LINEPROTO-5-UPDOWN:line protocol on interface ethernet0,changed state to down
%LINEPROTO-5-UPDOWN:line protocol on interface ethernet1,changed state to down
%LINEPROTO-5-UPDOWN:line protocol on interface serial0,changed state to down
%LINEPROTO-5-UPDOWN:line protocol on interface serial1,changed state to up
%PARSER-4-BADCFG: Unexpected end of configuration file.
%SYS-5-CONFIG: Configuration from network-confg by console tftp from 10.1.1.33
%SYS-5-CONFIG: Configuration from kim-confg by console tftp from 10.1.1.33
%SYS-5-RESTART: System restarted -
cisco internet work Operating System Software
IOS (tm) 250

 

  评论这张
 
阅读(173)| 评论(1)
推荐 转载

历史上的今天

在LOFTER的更多文章

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2018